While following the Setting Up a Metasploit Development Environment I ran into a few hiccups. Hopefully somebody else won't stumble if I write it down and share it.

Error: ruby-build: definition not found: 2.6.2

I think originally I was on an ubuntu system but I also ran into this when developing from Kali Linux.

apt-get remove ruby-build
git clone https://github.com/rbenv/ruby-build.git
cd ruby-build
sudo ./install.sh

rbev issues

rbev wasn't installed on my system right either. I had to follow the installation instructions from https://www.darkoperator.com/installing-metasploit-in-ubunt

Warning: the running version of Bundler (1.17.2) is older than the version that created the lockfile (1.17.3).

gem install bundler -v 1.17.3